Unix & Linux

Pytania i odpowiedzi dla użytkowników systemów Linux, FreeBSD i innych systemów operacyjnych typu Un * x


2
Dane wyjściowe statystyki w OSX
Chcę użyć statpolecenia, aby uzyskać informacje o pliku. Ja to zrobiłem: Josephs-MacBook-Pro:Desktop Joseph$ echo 'hello' > info.txt Josephs-MacBook-Pro:Desktop Joseph$ stat info.txt 16777220 21195549 -rw-r--r-- 1 Joseph staff 0 6 "Dec 21 20:45:31 2014" "Dec 21 20:45:30 2014" "Dec 21 20:45:30 2014" "Dec 21 20:45:30 2014" 4096 8 0 info.txt Trzeci …
15 osx  stat  portability 


3
btrfs ERROR: błąd podczas równoważenia - Brak miejsca na urządzeniu
W moim systemie Kubuntu 12.04 zabrakło miejsca na partycji głównej i nie można go uruchomić. Polecenie df -hpokazuje dużo dostępnego miejsca (przy użyciu tylko 37%): /dev/sda2 45G 17G 29G 37% Następująca strona wskazuje, że powinienem uruchomić komendę balance: https://btrfs.wiki.kernel.org/index.php/Problem_FAQ#I_get_.22Nie_space_left_on_device.22_errors.2C_but_df_says_I.27ve_got_lots_of_space $ sudo btrfs fi balance start -dusage=5 /mount/point Nie jestem do …

1
cUrl: lista argumentów jest za długa
Argument list too longPojawia się błąd: gdy próbuję użyć cUrl, aby wysłać plik w base64 w ciele mojego JSON. Używam czegoś takiego: DATA=$( base64 "$FILE" ) curl -X POST -H "Content-Type: application/json" -d '{ "data": "'"$DATA"'" }' $HOST Czy istnieje inny sposób na uzyskanie danych w ciele mojego JSON? Weź …
15 curl 


1
Instalowanie fail2ban na CentOS 7
Korzystam z odpowiedzi @GarethTheRed na to pytanie, aby zainstalować fail2ban na zdalnym serwerze CentOS 7. Jestem w stanie ukończyć wszystkie kroki, aż do momentu tail -f /var/log/fail2ban.log, w którym otrzymam inne wyniki niż on w swojej odpowiedzi. Oto wyniki, które otrzymuję na tym etapie: [root@remotecentosserver.com ~]# tail -f /var/log/fail2ban.log 2014-12-02 …
15 ssh  centos  openssh  sshd  fail2ban 

3
historia bash dla bieżącej sesji
Może coś pomijam, ale czy istnieje sposób na uzyskanie bieżącej historii bash dla bieżącej sesji, której używasz jeśli ucieknę ssh host $ pwd $ ls $ cd /tmp Chcę tylko zobaczyć te 3 polecenia i nic więcej

2
Jak uzyskać listę portów, które są wolne na serwerze Unix
Muszę wiedzieć, które porty w moim komputerze Solaris mogą być używane do dowolnego rodzaju komunikacji sieciowej. Próbowałem netstat -apolecenia. Ale zwrócone informacje nie dały przekonującego wyniku, którego wszystkich portów mogę używać do nowej aplikacji, którą piszę. Doceń wszelką pomoc udzieloną w tym zakresie.
15 networking 



5
Jak przekonwertować znaczniki czasu w kolumnie na datę?
Mam plik zawierający to: 1415602803,LOGIN SUCCESS,AUTH,user2,192.168.203.63,10.146.124.73,59996,22 1415602807,LOGIN SUCCESS,AUTH,user1,172.24.31.10,172.32.1.1,48191,22 1415602811,LOGIN FAILED,AUTH,root,172.24.166.153,10.146.124.73,52506,22 1415602815,LOGIN FAILED,AUTH,user3,192.168.123.55,10.146.32.99,55750,22 Chcę przekonwertować znacznik czasu na datę w tym formacie: 2014-11-10 02:00:03,LOGIN SUCCESS,AUTH,user2,192.168.203.63,10.146.124.73,59996,22 2014-11-10 02:00:07,LOGIN SUCCESS,AUTH,user1,172.24.31.10,172.32.1.1,48191,22 2014-11-10 02:00:11,LOGIN FAILED,AUTH,root,172.24.166.153,10.146.124.73,52506,22 2014-11-10 02:00:15,LOGIN FAILED,AUTH,user3,192.168.123.55,10.146.32.99,55750,22 Jak mogę to zrobić? Wiem, że to działa: perl -pe 's/(\d+)/localtime($1)/e'(z tego pytania ), ale format wyjściowy …

2
Problem z drukowaniem w ArchLinux i usłudze CUPS
Kilka dni (podejrzewam, że od czasu aktualizacji do gnome 3.14) na ArchLinux nie mogę już drukować. Jeśli otworzę panel drukowania centrum sterowania gnome, pojawia się komunikat (przetłumaczony z języka włoskiego): „Usługa systemowa drukowania nie jest dostępna” Więc z terminala próbowałem: $ sudo systemctl start cups Failed to start cups.service: Unit …

4
Przesyłanie milionów plików z jednego serwera na drugi
Mam dwa serwery. Jeden z nich ma 15 milionów plików tekstowych (około 40 GB). Próbuję przenieść je na inny serwer. Rozważałem spakowanie ich i przeniesienie archiwum, ale zdałem sobie sprawę, że to nie jest dobry pomysł. Więc użyłem następującego polecenia: scp -r usrname@ip-address:/var/www/html/txt /var/www/html/txt Zauważyłem jednak, że to polecenie przesyła …

1
Rozpocznij proces w tle od skryptu i zarządzaj nim po zakończeniu skryptu
Chciałbym uruchomić i skonfigurować proces podobnie do demona ze skryptu. Moja powłoka jest emulowana zsh pod Cygwin, a demonem jest SFK , podstawowy serwer FTP. Dla tego, co jest ważne, skrypt startserv.shmożna napisać w następujący sposób: #!/bin/sh read -s -p "Enter Password: " pw user=testuser share=/fshare cmd="sfk ftpserv -user=$user -pw=$pw …

Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.