błąd mount.cifs (2): Brak takiego pliku lub katalogu przy użyciu ścieżki przedrostka


11

Próbowałem tego polecenia:

mount -t cifs //server/share/directory /mnt/directory -o credentials=/path/to/cifs.credentials --verbose

Odpowiedź brzmi:

mount.cifs kernel mount options: ip=<IP of server>,unc=\\server \share,user=<username>,prefixpath=directory,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Jeśli jednak spróbuję wykonać to samo polecenie bez ścieżki prefiksu:

mount -t cifs //server/share /mnt/directory -o credentials=/path/to/cifs.credentials --verbose

Działa i mogę uzyskać dostęp do katalogu / mnt / directory /.

Otrzymuję ten sam błąd, jeśli wyraźnie podam ścieżkę przedrostka w opcjach, tj .:

mount -t cifs //server/share /mnt/directory -o credentials=/path/to/cifs.credentials,prefixpath=directory --verbose

Dodatkowe informacje:

  • Jestem w stanie połączyć się z żądaną ścieżką za pomocą smbclient //server/share -U username -W domain -D directory
  • Wersja mount.cifs: 5.5
  • Jądro Debiana 3.2.0-4-amd64
  • Jestem w stanie połączyć się na innym komputerze za pomocą mount.cifs w wersji 4.5 na jądrze Debiana 2.6.32-5-amd64

Wszelkie pomysły, dlaczego ścieżka przedrostka wydaje się powodować problem? Ta sama ścieżka działała ostatnio; Podejrzewam, że aktualizacja pakietu po stronie Linuksa lub aktualizacja Windowsa stoi za nowym zachowaniem.


Czy to na NAS? Kiedy mówisz, że próbujesz „bez ścieżki prefiksu”, polecenie wygląda tak samo. Czy to literówka?
— Octopus

To do SAN NetApp. Masz rację, to była literówka - poprawiłem to.
— cherdt

Technik wsparcia NetApp musiał zapewnić śledzenie pakietów, gdzie odkryli, że mount.cifs wysyła katalog // serwer / udział // zamiast // serwer / udział / katalog. To wydaje się być przyczyną problemu (choć nie jest rozwiązaniem).
— cherdt

Odpowiedzi:


6

W końcu znalazłem obejście tego problemu, które działa z naszą aplikacją NetApp. Jeśli nie potrzebujesz DFS, spróbuj zamontować z nodfsopcją.

mount -t cifs //server/share/directory /mnt/directory -ocredentials=/path/to/cifs.credentials,nodfs

Korzystamy również z netapp. Dzięki za obejście tego problemu uratowało mi to popołudnie.
— Danduk82
Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.