Nie można w pełni odinstalować i ponownie zainstalować Samby - unikalne błędy?


1

Uruchamianie serwera 16.04.1 32 z LXDE na górze. Właśnie zrobiłem sobie bałagan. Proszę pomóż. Chcesz to naprawić, aby lepiej zrozumieć Linuksa. Ponownie zainstaluj system operacyjny, ale nie chcę.

Odinstalowano Sambę za pomocą

sudo apt-get remove --purge samba

Próbowałem też tych

sudo apt-get -f install



dnsadmin@trm-linfs04:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up samba (2:4.3.11+dfsg-0ubuntu0.16.04.3) ...
Job for smbd.service failed because the control process exited with error code. See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Errors were encountered while processing:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)

    sudo apt-get autoremove


Job for smbd.service failed because the control process exited with error code. See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Errors were encountered while processing:
 samba
E: Sub-process /usr/bin/dpkg returned an error code (1)

Prawdopodobnie pomyłka przy czyszczeniu, ale ...

dnsadmin@trm-linfs04:~$ sudo dpkg --configure -a                                                                                Setting up samba (2:4.3.11+dfsg-0ubuntu0.16.04.3) ...
Job for smbd.service failed because the control process exited with error code.                                                 See "systemctl status smbd.service" and "journalctl -xe" for details.
invoke-rc.d: initscript smbd, action "start" failed.
dpkg: error processing package samba (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Errors were encountered while processing:
 samba
dnsadmin@trm-linfs04:~$ sudo status smbd
status: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/up                                                start: Connection refused
dnsadmin@trm-linfs04:~$ status: Unable to connect to Upstart: Failed to connect                                                 to socket /com/ubuntu/upstart: Connection refused
No command 'status:' found, did you mean:
 Command 'status' from package 'upstart' (main)
status:: command not found
dnsadmin@trm-linfs04:~$ serevice smbd status
No command 'serevice' found, did you mean:
 Command 'service' from package 'init-system-helpers' (main)
serevice: command not found
dnsadmin@trm-linfs04:~$ service smbd status
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2017-01-31 11:54:05 EST; 2min 21
     Docs: man:systemd-sysv-generator(8)
  Process: 12400 ExecStart=/etc/init.d/smbd start (code=exited, status=1/FAILURE

Jan 31 11:54:05 trm-linfs04 systemd[1]: Starting LSB: start Samba SMB/CIFS daemo
Jan 31 11:54:05 trm-linfs04 smbd[12400]:  * Starting SMB/CIFS daemon smbd
Jan 31 11:54:05 trm-linfs04 smbd[12400]:    ...fail!
Jan 31 11:54:05 trm-linfs04 systemd[1]: smbd.service: Control process exited, co
Jan 31 11:54:05 trm-linfs04 systemd[1]: Failed to start LSB: start Samba SMB/CIF
Jan 31 11:54:05 trm-linfs04 systemd[1]: smbd.service: Unit entered failed state.
Jan 31 11:54:05 trm-linfs04 systemd[1]: smbd.service: Failed with result 'exit-c
lines 1-13/13 (END)
● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
   Loaded: loaded (/etc/init.d/smbd; bad; vendor preset: enabled)
   Active: failed (Result: exit-code) since Tue 2017-01-31 11:54:05 EST; 2min 21s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 12400 ExecStart=/etc/init.d/smbd start (code=exited, status=1/FAILURE)

Jakieś pomysły?

Po prostu chcę się go całkowicie pozbyć i zainstalować ponownie.

Będzie używać Webmina 1.831 do zarządzania. Oczywiście nie mam pojęcia, co robię.

Każda pomoc byłaby wielka. Dzięki, Ubuntu Warriors!

Odpowiedzi:


0

Najpierw wyświetl listę wszystkich instancji zainstalowanych pakietów samba :

Polecenie dla wersji wcześniejszych niż 14.04 to:

 $ dpkg --get-selections | grep -v deinstall | egrep samba

Dla 14.04 i po tej komendzie jest:

 $ apt list --installed | egrep samba

Ten ostatni zawiera ostrzeżenie, które można zignorować. ( https://askubuntu.com/a/463966/29012 )

Teraz ręcznie ręcznie usuń te wystąpienia z danych wyjściowych za pomocą:

$ sudo apt remove [item from output]

Teraz wreszcie usuń niepotrzebne pakiety za pomocą:

$ sudo apt autoremove

Cóż, zadziałało doskonale. Dziękuję bardzo. Pierwsze polecenie z użyciem dpkg dało uproszczone wyjście, podczas gdy polecenie apt dało znacznie bardziej szczegółowe. Oba działały na moim pudełku 16.04.1.
— dns dave

Teraz chciałbym zrozumieć, co się właściwie dzieje. Wydaje się, że polecenie purge, które uruchomiłem na początku, po prostu cudziło pakiety do odinstalowania, ale nie wykonałem pełnego usunięcia / instalacji pakietów. Polecenie czyszczenia nie odinstalowało ich, ale je wyłączyło i sprawiło, że niektóre polecenia nie widziały ich do przetworzenia? Jakieś krótkie wyjaśnienie, jak faktycznie działa proces odinstalowywania i jaka jest najlepsza praktyka w przypadku instalacji 16.04? Dzięki jeszcze raz.
— dns dave

@davidintheusa Cieszę się, że zadziałało. Rozważ kliknięcie szarego znacznika wyboru, aby zaznaczyć odpowiedź jako zaakceptowaną.
— LD James

James, nowy w tym. Dostanie głosowanie, sprawdzanie w dół. Dzięki.
— dns dave
Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.