MongoDB (3.2) nie uruchamia się na Lubuntu 16.04 LTS jako usługa


26

Z jakiegokolwiek powodu przy każdej próbie uruchomienia MongoDB jako usługi ( sudo service mongod start) pojawia się następujący błąd:

Failed to start mongod.service: Unit mongod.service not found.

Postępowałem zgodnie z instrukcją instalacji na stronie MongoDB.

Odpowiedzi:


58

Instrukcje / pakiety na stronie MongoDB są obecnie dostępne tylko dla LTS Ubuntu 12.04 i 14.04. Pakiety są skonfigurowane do używania upstart zamiast systemd. Musisz utworzyć plik systemctl, aby był gotowy na systemd. Utwórz przez

sudo nano /etc/systemd/system/mongodb.service

Będzie to wyglądać

[Unit]
Description=High-performance, schema-free document-oriented database
After=network.target

[Service]
User=mongodb
ExecStart=/usr/bin/mongod --quiet --config /etc/mongod.conf

[Install]
WantedBy=multi-user.target

Teraz możesz uruchomić usługę i sprawdzić jej stan za pomocą

sudo systemctl start mongodb
sudo systemctl status mongodb

i na koniec włącz to na stałe przez

sudo systemctl enable mongodb

(Źródło: Jak zainstalować MongoDB na Ubuntu 16.04 )


Czasami nie uruchamia się z powodu błędu SIECI. W takim przypadku spróbuj usunąć plik skarpety w / tmp
— Nidhin David

Oficjalnym sposobem na to jest użycie mongod dla nazwy usługi
— Luca Steeb

4
Postępował zgodnie z tymi instrukcjami i próbował uruchomić sudo systemctl start mongodb, ale pojawił się następujący komunikat o błędzie: „Uruchomienie mongodb.service: jednostka mongodb.service jest maskowana”. Uruchomienie „sudo systemctl unmask mongodb” naprawiło błąd
— Robert Townley

właśnie uratowałeś mi dzień
— Rahul Kumar

Dzięki dziennikowi JeffRSon, to uratowało mi dzień, walczyłem, żeby to zadziałało.
— Pionier

5

Wystarczy uruchomić, sudo mongodaby uruchomić demona, a następnie sudo mongouzyskać dostęp do powłoki


10
Czy zawsze w ten sposób uruchamiasz bazy danych na swoich serwerach?
— ruX

niestety to zadziałało dla mnie ... Musiałem więc zmienić uprawnienia użytkownika mongo
— Jamie Hutber

to zadziałało dla mnie, ale potrzebowałem też cd /, następnie sudo mkdir data, a następnie sudo mkdir / data / db.
— edencorbin

0

Uruchomienie następującego polecenia działało dla mnie. Uruchom mongo z plikiem konfiguracyjnym.
Po prostu biegnij mongod --config /etc/mongod.conf.


1
ta opcja została usunięta w
— Mongo
Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.