Wystąpił błąd z dpkg


8

Niedawno zaktualizowałem serwer 14.04 do wersji 14.10 i otrzymałem ten komunikat o błędzie podczas aktualizacji:

Konfigurowanie sysv-rc (2.88dsf-41ubuntu18) ...
informacje: Zmiana kolejności systemu rozruchowego, zaloguj się do /var/lib/insserv/run-20141030T2142.log
błąd: Wystąpił błąd podczas migracji.

błąd: nie można przeprowadzić migracji do sekwencji rozruchu opartej na zależnościach.

Zobacz http://wiki.debian.org/LSBInitScripts/DependencyBasedBoot dla
więcej informacji na temat sekwencjonowania rozruchu opartego na zależności. Do
ponów próbę procesu migracji, uruchom „dpkg --configure sysv-rc”.

dpkg: pakiet przetwarzania błędów sysv-rc (--configure):
 podproces zainstalowany skrypt poinstalacyjny zwrócił błąd wyjścia status 1

Ilekroć instaluję pakiety / używam dpkg, pojawia się bardzo podobny błąd. To się nigdy nie wydarzyło 14.04.



EDYCJA: Dodano poniżej dziennik, który może zawierać więcej informacji

info: Konwertowanie rc0.d / S * i rc6.d / S * na K *.
ls: nie można uzyskać dostępu do S *: brak takiego pliku lub katalogu
ls: nie można uzyskać dostępu do S *: brak takiego pliku lub katalogu
info: running insserv
insserv: ostrzeżenie: w skrypcie „wide-dhcpv6-client” brakuje tagów i przesłonięć LSB
insserv: ostrzeżenie: w skrypcie „bind9” brakuje tagów i przesłonięć LSB
insserv: Jeśli zatrzymano, istnieje pętla między usługą bind9 a apache2
insserv: pętla obejmująca apache usługi 2 na głębokości 2
insserv: pętla obejmująca usługę bind9 na głębokości 1
insserv: pętla obejmująca wysyłkę usług na głębokości 4
insserv: wychodzenie teraz bez zmiany kolejności rozruchu!

więc co się stanie, gdy uruchomisz „dpkg --configure sysv-rc” zgodnie z zaleceniami?
Panther

pojawia się ten sam komunikat o błędzie
wolfy1339,

Jest to błąd i nie opublikowałeś wystarczająco dużo informacji, aby udzielić odpowiedzi. Dyskusja tutaj - unix.stackexchange.com/questions/145964/... ale nie widziałem poprawki
Panther

umieściłem najnowszy dziennik w moim poście
wolfy1339,

usuń apache i powiąż 9 i spróbuj ponownie. Następnie ponownie zainstaluj apache i powiąż 9.
Panther

Odpowiedzi:


8

Miałem dokładnie ten sam problem, ale w moim przypadku był on spowodowany przez virtuoso-nepomukskrypt.

Zamiast usuwać bind9i apachesugerowałbym po prostu przeniesienie ich skryptów z /etc/init.dkatalogu. Powinno to pozwolić na zakończenie procesu, a następnie możesz zrobić apt-get install --reinstall ...na tych pakietach po zakończeniu aktualizacji, aby poprawnie skonfigurować ich uruchamianie.


3

Wygląda na to, że masz błędy w plikach konfiguracyjnych dla bind9 i wide-dhcpv6-client. Jeśli nie edytowałeś ich samodzielnie (tzn. Używasz / chcesz użyć domyślnego zachowania klienta DHCP / DNS), powinieneś wydać

apt-get install --reinstall bind9 wide-dhcpv6-client

a gdy pojawi się pytanie, czy chcesz zachować bieżące pliki konfiguracyjne, powiedz, aby zastąpił je wersją opiekuna pakietu.

Ten problem wystąpił po użyciu aktualizacji do-release do przejścia z wersji Trusty na Xenial. Wydaje mi się, że gdzieś tam nie do końca zaktualizowano z Upstart do systemowego. W każdym razie powyższe rozwiązało problem dla mnie.

Jeśli apt zgłasza błędy w twoich plikach konfiguracyjnych dla serwera DHCP, prawdopodobnie i tak chcesz je rozwiązać. Odpowiedź 3vi1 po prostu wepchnęła możliwy problem pod dywan, aby skłonić apt do robienia tego, co chcesz.


-1

Robiąc to na laptopie Dell Precision M3800 z Ubuntu, musiałem zrobić to samo /etc/init.d/dell*.

Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.