Nie można uzyskać dostępu do repozytorium VisualSVN za pośrednictwem HTTPS


1

Mam VisualSVN Server działający w systemie Windows 7 64-bit. Repozytorium znajduje się w C: \ Repositories. Kiedy próbuję uzyskać do niego dostęp przez HTTPS, pojawia się następujący błąd:

Nie można otworzyć żądanego systemu plików SVN, kod błędu 500 # 720005.

Próbowałem przyznać administratorowi pełne prawa do katalogu repozytorium, ale to nie działa. Jedynym sposobem, w jaki mogę uzyskać dostęp przez HTTPS, jest przyznanie wszystkim pełnych praw, co jest oczywiście niebezpieczne.

Jak mogę przyznać dostęp do repozytorium tylko określonym użytkownikom?

Próbowałem również zwolnić odpowiednie katalogi z pełnym dostępem do użytkownika „Netzwerkdienst” (= usługa sieciowa), który również nie działa. Działa tylko zwolnienie katalogów dla użytkownika „Jeder” (= Wszyscy).

Załączono wpis Logger: Protokollname: VisualSVNServer Quelle: VisualSVN Server 2.5 Data: 22.02.2013 08:57:24 Ereignis-ID: 1003 Kategoria: (2) Ebene: Fehler Schlüsselwörter: Klassisch Benutzer: Nicht zutreffend Computer: TZEMod

Nie można otworzyć pliku hasła: C: / Repositories / htpasswd (OS 5) Zugriff verweigert [klient fe80 :: 8136: f1b6: 6e71: cb91] Ereignis-XML:; 1003 2 2 0x80000000000000

454 VisualSVNServer TZEModbusLogger Nie można otworzyć pliku hasła: C: / Repositories / htpasswd (OS 5) Zugriff verweigert fe80 :: 8136: f1b6: 6e71: cb91


VisualSVN prawdopodobnie działa jako LOCAL SERVICEkonto systemowe, czy próbowałeś dać temu dostęp?
— themel

Nie! Usługa serwera VisualSVN domyślnie działa na koncie „Usługa sieciowa”.
— bahrep

Sprawdź dziennik serwera. Jakie zdarzenia są tam generowane? Zobacz visualsvn.com/support/topic/00028
— bahrep

Próbowałem również zwolnić odpowiednie katalogi z pełnym dostępem do użytkownika „Netzwerkdienst” (= usługa sieciowa), który również nie działa. Działa tylko zwolnienie katalogów dla użytkownika „Jeder” (= Wszyscy). Załączono wpis Logger: Protokollname: VisualSVNServer Quelle: VisualSVN Server 2.5 Data: 22.02.2013 08:57:24 Ereignis-ID: 1003 Kategoria: (2) Ebene: Fehler Schlüsselwörter: Klassisch Benutzer: Nicht zutreffend Computer: TZEMod
— KIJO

Nie można otworzyć pliku hasła: C: / Repositories / htpasswd (OS 5) Zugriff verweigert [klient fe80 :: 8136: f1b6: 6e71: cb91] Ereignis-XML: <Event xmlns = " schemas.microsoft.com/win/2004/ 08 / events / event "> <System> <Provider Name =" VisualSVN Server 2.5 "/> <EventID Qualifiers =" 0 "> 1003 </EventID> <Level> 2 </Level> <Task> 2 </Task> <Ke words> 0x80000000000000 </Ke words> <TimeCreated SystemTime = "2013-02-22T07: 57: 24.000000000Z" />
— KIJO
Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.