Co to jest błąd EXT4-fs (urządzenie md0): ext4_mb_generate_buddy: 739: grupa 10770, 0 klastrów w bitmapie, 32768?


6

Na moim Ubuntu Server 12.04 dostałem te błędy (przez dmesg):

[ 1104.544121] EXT4-fs error (device md0): ext4_mb_generate_buddy:739: group 10771, 0 clusters in bitmap, 32768 in gd
[ 1104.549227] EXT4-fs error (device md0): ext4_mb_generate_buddy:739: group 10772, 0 clusters in bitmap, 32768 in gd
[ 1151.872640] EXT4-fs error (device md0): ext4_mb_generate_buddy:739: group 10784, 28639 clusters in bitmap, 28640 in gd

Nie mam pojęcia, dlaczego pojawiają się te błędy.

Konfiguracja mojego serwera:

  • 1 x dysk twardy SATA dla systemu operacyjnego
  • 4 x 2 TB SATA HDD (urządzenie MD0 ): RAID 5 na EXT4

Możliwe źródła błędów:

  • Ja (lub system automatycznie) dokonałem ponownej synchronizacji , ponieważ jeden kabel SATA został uszkodzony.
  • Skopiowałem niektóre pliki z zewnętrznego dysku twardego z NTFS do systemu RAID EXT4 (ale chyba nie powinien to być problem).

Poszukałem google, ale nie znalazłem rozwiązania. Mogę spróbować:

  • Polecenie fsck (nie można podać linku, ze względu na ochronę przed spamem superuser.com ..), aby coś naprawić? Może to pomaga ...
  • Poczekaj na rozwiązanie tego wpisu o błędzie jądra systemu Linux

Okej, myślę, że polecenie resync i fsck rozwiązało problem. Błędy nie pojawiają się ponownie.
— malisokan

Odpowiedzi:


1

Powinieneś spróbować odmontować dysk i uruchomić na nim fsck. Co pokazuje to polecenie?

cat /proc/mdstat

Dyski powinny być zsynchronizowane, aby można było naprawić system plików.


Okej, myślę, że polecenie resync i fsck rozwiązało problem. Błędy nie pojawiają się ponownie.
— malisokan

Czy mógłbyś rozwinąć tę mdstatsprawę? Rozwiązałem komunikat o błędzie systemu plików w moim Kali Linux na Raspberry przez fscking, ale nie mam takiego /proc/mdstatpliku (cóż, jest to wersja Raspberry).
— Sopalajo de Arrierez

/ proc / mdstat to plik statusu pakietu mdadm multi-disk-admin służącego do zarządzania RAID. Jeśli nie robisz czegoś bardzo niezwykłego, nie masz RAID na malinowym pi, a to nie ma zastosowania. Porada polega po prostu na upewnieniu się, że dane macierzy RAID są synchronizowane między dyskami przed przystąpieniem do naprawy na poziomie systemu plików.
— superboot

Po raz drugi zgadłeś i nie odpowiedziałeś na pytanie. Pytanie brzmi, co oznacza wiadomość, dlaczego tak się dzieje. Zamiast tego mówisz, jak to naprawić.
— Eric

0

Te komunikaty są spowodowane wykryciem przez ext4 niedopasowania w liczbie wolnych bloków między mapami bitowymi alokatora znajomych ext4 a liczbą wolnych bloków w deskryptorze grupy. Może to być wynikiem uszkodzenia map bitowych. W przypadku niedopasowania kod zaktualizuje liczbę wolnych bloków deskryptorów grupy o obliczoną wartość z map bitowych, aby upewnić się, że będą pasować w przyszłości. Dokładna przyczyna tego problemu jest nadal badana w prywatnej Bugzilli, ale przyczyną zdalnych przypadków przechowywania wydaje się być sprzęt / oprogramowanie układowe w większości przypadków.

źródło: https://access.redhat.com/solutions/155873

Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.