Błąd httpd Apache „proxy: ap_get_scoreboard_lb” z ProxyPass


12

Skonfigurowałem apache do proxy dla tomcat, ale pojawia się następujący błąd podczas kierowania na stronę. Czasami dostaję pustą stronę lub 503:

[Błąd]

[Mon Dec 03 04:58:16 2012] [error] proxy: ap_get_scoreboard_lb(2) failed in child 29611 for worker proxy:reverse
[Mon Dec 03 04:58:16 2012] [error] proxy: ap_get_scoreboard_lb(1) failed in child 29611 for worker https://localhost:8443/
[Mon Dec 03 04:58:16 2012] [error] proxy: ap_get_scoreboard_lb(0) failed in child 29611 for worker http://localhost:8080/

Mam dwa hosty vhost skonfigurowane na maszynie wirtualnej w następujący sposób:

[host http]

<VirtualHost *:80>
  ServerName www.mysite.net
  ServerAlias mysite.net

  ProxyRequests Off
  ProxyPreserveHost On

  <Proxy *>
    Order deny,allow
    Allow from all
  </Proxy>

  ProxyPass / http://localhost:8080/ retry=0
  ProxyPassReverse / http://localhost:8080/ retry=0
</VirtualHost>

[ssl vhost]

<VirtualHost *:443>
        ServerName www.mysite.net
        ServerAlias mysite.net

        ErrorLog /var/log/apache2/error.log

        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

        SSLEngine on
        SSLProxyEngine on
        SSLCertificateFile /etc/apache2/ssl/server.crt
        SSLCertificateKeyFile /etc/apache2/ssl/server.key

        ProxyRequests Off
        ProxyPreserveHost On
        ProxyPass / https://localhost:8443/ retry=0
        ProxyPassReverse / https://localhost:8443/ retry=0

</VirtualHost>

Moje dane systemowe to: Apache / 2.2.22 (Ubuntu) mod_jk / 1.2.32 mod_ssl / 2.2.22 OpenSSL / 1.0.1 mod proxy_http jest również włączony.

Odpowiedzi:


10

Wygląda na to, że istnieje różnica między zatrzymaniem a następnie uruchomieniem apache i apachectl gracefulponownym uruchomieniem (tj. Zatrzymaniem i uruchomieniem w przeciwieństwie do restartu apachectl ), jak stwierdzono na tej stronie :

This is a bit of a guess, and probably wrong, but does stopping and 
starting the server rather than restarting (they're different, 
restarting (including gracefully) doesn't kill the master process) 
help? As I understand it, there are issues in mod_proxy regarding the 
scoreboard size when changes to the config are made between restarts.

1
FWIW, apachectl restartto też za mało; Musiałem zrobić, apachectl stop; apachectl startaby zapobiec wystąpieniu tego błędu (także z Apache httpd 2.2.2).
— Nicholas Riley

@NicholasRiley autorstwa Yeah Właśnie to miałem na myśli przez ponowne uruchomienie. Być może powinienem był wyjaśnić tę kwestię.
— Dark Star1

Dzięki za to. Pojawiały się te same błędy, kiedy zmieniałem konfigurację serwera proxy do przodu, a następnie ponownie uruchamiałem za pomocą graceful.
— Anthony Geoghegan
Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.