Problem z instalacją Magento 2: błąd 404 podczas próby załadowania strony administratora


11

Pomyślnie zainstalowałem Magento 2 na serwerze Wamp, ale mam niewielki problem z ładowaniem strony administratora, ponieważ daje mi 404. Ponadto, podczas ładowania jej strony głównej domyślny motyw, którym w moim przypadku jest Luma, nie ma zastosowania i zamiast tego daje mi następujące błędy:

Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/mage/calendar.css     
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-m.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-l.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/print.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/images/logo.svg    
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-m.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/styles-l.css 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/requirejs/require.js 
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/css/print.css     
Failed to load resource: the server responded with a status of 404 (Not Found)
http://127.0.0.1/test1/pub/static/frontend/Magento/luma/en_US/mage/requirejs/mixins.js 
Failed to load resource: the server responded with a status of 404 (Not Found)
requirejs-config.js:602 Uncaught ReferenceError: require is not defined
127.0.0.1/:24 Uncaught ReferenceError: require is not defined
127.0.0.1/:26 Uncaught ReferenceError: require is not defined

Odpowiedzi:


18

Css i js zostaną utworzone w czasie wykonywania w folderze pub / static Po raz pierwszy, jeśli brakuje css i js, uruchom polecenie poniżej

jeśli używasz systemu Windows: php bin\magento setup:static-content:deploy

jeśli używasz linuxa „git bash”: php bin/magento setup:static-content:deploy


Upewnij się także, że włączyłeś przepisywanie serwera Apache
— Steve Johnson

Byłbym wdzięczny, gdybyś mógł rozbić kroki. Jak uruchomić polecenie systemu Windows? Jak się dowiedzieć, czy to rzeczywiście działało?
— Mohammed Joraid

Nie jest nic warte, że jeśli pobrałeś źródło z github i instalowałeś przez przeglądarkę, musisz włączyć tryb programisty. Powyższe polecenie narzeka, że ​​nie musisz uruchamiać setup:static-content:deployw trybie programisty, więc upewnij się, że dołączasz -fdo powyższego polecenia. Jeśli ustawiłeś inny język niż en_US, musisz także podać te:php bin\magento setup:static-content:deploy -f en_US en_GB
— BugHunterUK

12

Miałem również do czynienia z tym problemem. Administrator podaje błąd 404 i frontend nie dołączał css (tj. Luma nie wyświetlał się we właściwym formacie ..). Więc zrobiłem te kroki, aby rozwiązać oba problemy w Magento 2. 1) udałem się do terminalu i uruchomiłem to polecenie

sudo gedit /etc/apache2/apache2.conf

I zmień: -

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride none
Require all granted

Do

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

chnage only AllowOverride none to All

i

2) przejdź do terminala i uruchom polecenie: -

sudo a2enmod rewrite
sudo service apache2 restart

Następnie udziel zezwolenie na swój var, pub i aplikację / etc. a następnie przejdź do administratora i nakładka działa poprawnie.


1
człowieku, wypróbowałem tysiące rozwiązań, ale tylko ten działał dla mnie bardzo dzięki!
— Wasif Khalil

8

Dla tych, którzy używają serwera Wamp, uruchom te polecenia w swoim CLI.

C: \ wamp \ bin \ php \ php5.5.12> php.exe
C: \ wamp \ www \\ bin \ magento setup: static-content: deploy


6

Miałem również do czynienia z tym problemem. Po świeżej instalacji Magento 2 z danymi demo podczas nawigacji do frontendu i backendu również w localhost. Wystąpiły błędy niedopasowania typu MIME dla calendar.css i wymagają.js. Nic nie działało dla mnie, chyba że wdrożono statyczną zawartość przez

php bin/magento setup:static-content:deploy

w git bash i gdy jest to tryb domyślny.



2

Włącz przepisywanie adresów URL.

1) Otwórz terminal w Ubuntu i wykonaj następujące polecenia:

sudo a2enmod rewrite

sudo service apache2 restart

2) Upewnij się, że masz .htaccessplik w katalogu głównym magento, jeśli nie ma go. htaccessplik skopiuj /pub/.htaccessplik i wklej go do katalogu głównego

3) Otwórz /etc/apache2/apache2.confplik za pomocą następujących poleceń:

sudo nano /etc/apache2/apache2.conf

I zmień następujące wiersze kodu:

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride none
Require all granted

Do

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted

Zapisz i zamknij plik według Ctrl + X

  • Uruchom ponownie apache

    usługa sudo apache2 restart

Korzystając z naszej strony potwierdzasz, że przeczytałeś(-aś) i rozumiesz nasze zasady używania plików cookie i zasady ochrony prywatności.
Licensed under cc by-sa 3.0 with attribution required.